Skip to main content
VulnerabilityPublished

CVE-2025-30220: geoserver · XML External Entity (XXE)

Affects geoserverSource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · 42% EPSS · CVSS 9.9 Critical · fixed in 2.25.7 : patch geoserver as a priority.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
42.2% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.25.7, 33.1, 32.3 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2025

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade geoserver/geoserver to 2.25.7; geotools/geotools to 33.1, 32.3, 31.7 or 28.6.1; geonetwork/core-geonetwork to 4.4.8 or 4.2.13.

Affected software

ProductAffectedFixed in
GitHubgeoserver/geoserverpkg:github/geoserver/geoserverOther threatsAffected
  • <2.25.7
Fixed in
  • 2.25.7
GitHubgeotools/geotoolspkg:github/geotools/geotoolsOther threatsAffected
  • <28.6.1
  • <31.7
  • <32.3
  • <33.1
Fixed in
  • 28.6.1
  • 31.7
  • 32.3
  • 33.1
GitHubgeonetwork/core-geonetworkpkg:github/geonetwork/core-geonetworkOther threatsAffected
  • <4.2.13
  • <4.4.8
Fixed in
  • 4.2.13
  • 4.4.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate patching: Upgrade GeoServer installations to versions 2.27.1, 2.26.3, or 2.25.7 and GeoTools to versions 33.1, 32.3, 31.7, or 28.6.1 as applicable.
  2. Configuration review: Ensure that XML parsers used by GeoServer and GeoTools are configured to disable external entity resolution and DTD processing unless explicitly required and safely managed.
  3. Network segmentation: Restrict GeoServer’s network access to limit outbound connections, preventing SSRF exploitation from reaching internal resources.
  4. Input validation: Implement strict validation and sanitization of all XML inputs, especially those that reference external schemas.
  5. Monitoring and logging: Enable detailed logging of XML processing errors and monitor for unusual outbound requests or access patterns indicative of exploitation attempts.
  6. Access controls: Limit exposure of GeoServer interfaces to trusted networks or VPNs where possible.
  7. Incident response preparedness: Develop and test incident response plans specific to geospatial data breaches and XXE exploitation scenarios.
  8. Vendor advisories: Stay updated with GeoServer and GeoTools security advisories for any further patches or mitigation guidance.

Description

GeoServer is an open source server that allows users to share and edit geospatial data. GeoTools Schema class use of Eclipse XSD library to represent schema data structure is vulnerable to XML External Entity (XXE) exploit. This impacts whoever exposes XML processing with gt-xsd-core involved in parsing, when the documents carry a reference to an external XML schema. The gt-xsd-core Schemas class is not using the EntityResolver provided by the ParserHandler (if any was configured). This also impacts users of gt-wfs-ng DataStore where the ENTITY_RESOLVER connection parameter was not being used as intended. This vulnerability is fixed in GeoTools 33.1, 32.3, 31.7, and 28.6.1, GeoServer 2.27.1, 2.26.3, and 2.25.7, and GeoNetwork 4.4.8 and 4.2.13.

References

Community reviews

Loading reviews…