CVE-2025-34305: IPFire · XSS or 'Cross-site Scripting'
Affects IPFireSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium · fixed in 2.29 : update IPFire when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| IPFire.org IPFire | Affected
| Fixed in– |
AI-suggested
European organizations should immediately verify their IPFire version and upgrade to version 2.29 (Core Update 198) or later where this vulnerability is fixed. If upgrading is not immediately feasible, administrators should restrict access to the IPFire web interface to trusted networks and users only, employing strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of credential compromise. Regularly audit user accounts and permissions to minimize the number of users who can submit data to the vulnerable endpoints. Implement web application firewall (WAF) rules to detect and block suspicious input patterns targeting the affected CGI scripts. Additionally, monitor logs for unusual POST requests to the vulnerable endpoints and for unexpected script execution behaviors. Educate users with access to the IPFire interface about the risks of XSS and the importance of not clicking on suspicious links or submitting untrusted input. Finally, maintain a robust patch management process to ensure timely application of security updates.
Description
IPFire versions prior to 2.29 (Core Update 198) contain multiple stored cross-site scripting (XSS) vulnerabilities caused by a bug in the cleanhtml() function (/var/ipfire/header.pl) that fails to apply HTML-entity encoding to user input. When an authenticated user submits data to affected endpoints - for example, POST /cgi-bin/wakeonlan.cgi (CLIENT_COMMENT), /cgi-bin/dhcp.cgi (ADVOPT_DATA, FIX_REMARK, FIX_FILENAME, FIX_ROOTPATH), /cgi-bin/connscheduler.cgi (ACTION_COMMENT), /cgi-bin/dnsforward.cgi (REMARK), /cgi-bin/vpnmain.cgi (REMARK), or /cgi-bin/dns.cgi (REMARK) - the application calls escape() and HTML::Entities::encode_entities() but never assigns the sanitized result back to the output variable. The original unsanitized value is therefore stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected entries.