CVE-2025-34307: IPFire · XSS or 'Cross-site Scripting'
Affects IPFireSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade IPFire to 2.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| IPFire.org IPFire | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2025-34307, European organizations should immediately upgrade IPFire installations to version 2.29 (Core Update 198) or later, where the vulnerability is addressed. If upgrading is not immediately feasible, administrators should restrict access to the IPFire web interface to trusted networks and users only, employing network segmentation and VPNs to limit exposure. Implement multi-factor authentication (MFA) for all IPFire administrative accounts to reduce the risk of credential compromise. Regularly audit user accounts and access logs to detect suspicious activity. Additionally, administrators can monitor and sanitize inputs related to the pienumber parameter manually or via custom web application firewalls (WAFs) as a temporary measure. Educate users with administrative access about the risks of stored XSS and encourage cautious behavior when interacting with firewall configuration interfaces. Finally, maintain up-to-date backups of firewall configurations to enable rapid recovery in case of compromise.
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the pienumber parameter when updating the firewall country search defaults. When a user updates the default values for the firewall country search, the application issues an HTTP POST request to /cgi-bin/logs.cgi/firewalllogcountry.dat and the default number of countries to display is provided in the pienumber parameter. The value of this parameter is stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected firewall country search settings.