Skip to main content
CVE-2025-48888VulnerabilityPublished

CVE-2025-48888: denoland deno · Incorrect Authorization

Affects denoland denoSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 2.3.2 : update denoland deno when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.2, 2.2.13, 2.1.13
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade denoland/deno to 2.3.2, 2.2.13 or 2.1.13.

Affected software

ProductAffectedFixed in
GitHubdenoland/denopkg:github/denoland/denoOther threatsAffected
  • <2.1.13
  • <2.2.13
  • <2.3.2
  • =1.41.3
Fixed in
  • 2.1.13
  • 2.2.13
  • 2.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability effectively, European organizations should: 1) Immediately upgrade all Deno runtimes to versions 2.1.13, 2.2.13, or 2.3.2 where the issue is patched. 2) Audit existing Deno scripts and deployment pipelines to ensure that permission flags are not set in conflicting or nonsensical combinations, particularly avoiding simultaneous use of `--allow-*` and `--deny-*` flags for the same permission. 3) Implement strict code review and deployment policies to prevent unvetted or user-supplied permission flags from being used in production environments. 4) Employ runtime monitoring and logging to detect unusual permission flag usage or unexpected file access patterns during Deno script execution. 5) Where possible, isolate Deno execution environments using containerization or sandboxing to limit the blast radius of any potential exploitation. 6) Educate developers and DevOps teams about the correct usage of Deno permission flags and the risks of improper authorization configurations. These steps go beyond generic patching advice by focusing on operational controls and secure configuration management tailored to this specific vulnerability.

Description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, `deno run --allow-read --deny-read main.ts` results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as `--allow-* --deny-*`. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.

References

Community reviews

Loading reviews…