CVE-2025-48944: vllm · Improper Input Validation
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.9.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade vllm-project/vllm to 0.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubvllm-project/vllmpkg:github/vllm-project/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading vLLM to version 0.9.0 or later, where this input validation flaw is fixed. Until the upgrade is applied, organizations should implement strict input validation and sanitization at the API gateway or proxy level to filter out malformed or unexpected inputs in the "pattern" and "type" fields. Rate limiting and anomaly detection on the /v1/chat/completions endpoint can help detect and block suspicious requests that may trigger crashes. Monitoring the health of inference workers and automating restart procedures can reduce downtime impact. Additionally, restricting access to the API endpoint to trusted networks or authenticated users with minimal privileges can reduce exploitation risk. Organizations should also review internal policies to limit who can invoke the tools functionality and audit logs for unusual request patterns. Finally, security teams should stay alert for any emerging exploit reports and apply patches promptly.
Description
vLLM is an inference and serving engine for large language models (LLMs). In version 0.8.0 up to but excluding 0.9.0, the vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Version 0.9.0 fixes the issue.