Skip to main content
VulnerabilityPublished Updated

CVE-2025-53493: Wikimedia Foundation Mediawiki – MintyDocs Extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – MintyDocs ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.44.0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Wikimedia Foundation Mediawiki – MintyDocs Extension to 1.44.0.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - MintyDocs ExtensionAffected
  • >=1.43.0 <1.44.0
Fixed in
  • 1.44.0

AI-suggested

To mitigate this vulnerability, European organizations should prioritize upgrading the MintyDocs extension to version 1.43.2 or later once it becomes available, as this will likely contain the official fix. Until then, organizations should implement strict input validation and output encoding on all user-supplied content within the MintyDocs extension to neutralize potentially malicious scripts. Employing Content Security Policy (CSP) headers can help restrict the execution of unauthorized scripts in browsers. Additionally, organizations should audit their Mediawiki installations to identify any instances of the MintyDocs extension and assess exposure. Monitoring logs for unusual activities or injection attempts can provide early detection of exploitation attempts. User privileges should be reviewed to limit who can create or edit content in the MintyDocs extension, reducing the attack surface. Finally, educating users about the risks of XSS and encouraging cautious behavior when interacting with wiki content can help mitigate social engineering vectors that might accompany exploitation.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - MintyDocs Extension allows Stored XSS.This issue affects Mediawiki - MintyDocs Extension: from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…