Skip to main content
VulnerabilityPublished Updated

CVE-2025-53502: Wikimedia Foundation Mediawiki – FeaturedFeeds Extension · Improper Input Validation

Affects Wikimedia Foundation Mediawiki – FeaturedFeeds ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 1.44.0 : update Wikimedia Foundation Mediawiki – FeaturedFeeds Extension when convenient.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.0, 1.40.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade wikimedia/mediawiki/extensions/FeaturedFeeds to 1.44.0, 1.43.0 or 1.40.0.

Affected software

ProductAffectedFixed in
GitHubwikimedia/mediawiki/extensions/FeaturedFeedspkg:github/wikimedia/mediawiki/extensions/FeaturedFeedsOther threatsAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-53502, organizations should promptly update the FeaturedFeeds Extension to a patched version once available from the Wikimedia Foundation. If you cannot patch yet, administrators should consider disabling the FeaturedFeeds Extension if it is not critical to operations. Implementing a Web Application Firewall (WAF) with rules to detect and block typical XSS payloads targeting Mediawiki can provide interim protection. Additionally, organizations should enforce Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing the wiki. Regularly auditing and sanitizing user-generated content and inputs within the wiki environment can reduce risk. Monitoring logs for suspicious activity related to the FeaturedFeeds Extension and educating users about the risks of clicking on untrusted links within the wiki can further enhance security. Finally, organizations should maintain an incident response plan to quickly address any exploitation attempts.

Description

Improper Input Validation vulnerability in Wikimedia Foundation Mediawiki - FeaturedFeeds Extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - FeaturedFeeds Extension: 1.39.X, 1.42.X, 1.43.X.

References

Community reviews

Loading reviews…