CVE-2025-53905: vim · Path Traversal
Affects vimSource GCVE Database
Not known to be exploited · CVSS 4.1 Medium : upgrade to 9.1.1552 when convenient.
Data as of 4 Nov 2026, 17:36 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 4.1 |
|---|
- Patch
- Available – fixed in 9.1.1552
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade vim to 9.1.1552.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vim vim | Affected
| Fixed in
|
AI-suggested
Upgrade Vim to version 9.1.1552 or later, which contains a patch for this vulnerability. No additional mitigation is required once the update is applied.
Description
A path traversal vulnerability exists in Vim's tar.vim plugin prior to version 9.1.1552. This flaw allows an attacker to overwrite arbitrary files by opening specially crafted tar archives. Exploitation requires direct user interaction, specifically editing a malicious archive with Vim. The vulnerability can lead to overwriting sensitive files or placing executable code in privileged locations depending on user permissions. Version 9.1.1552 includes a patch that fixes this issue.