Skip to main content
CVE-2025-54123VulnerabilityPublished

CVE-2025-54123: SpectoLabs hoverfly · Improper Input Validation

Affects SpectoLabs hoverflySource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · 10% EPSS · CVSS 9.8 Critical.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
10.5% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2025

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
SpectoLabs hoverflyAffected
  • <=1.11.3
Fixed in–

AI-suggested

1. Immediately upgrade Hoverfly to a version later than 1.11.3 where the set middleware API is disabled by default or patched to prevent command injection. 2. If upgrading is not immediately possible, disable or restrict access to the `/api/v2/hoverfly/middleware` endpoint, ideally limiting it to trusted internal networks or via VPN. 3. Implement strict network segmentation and firewall rules to prevent unauthorized external access to Hoverfly services. 4. Monitor logs and network traffic for unusual activity related to the middleware API endpoint, such as unexpected command executions or reverse shell attempts. 5. Conduct a thorough audit of systems running Hoverfly to detect any signs of compromise or unauthorized command execution. 6. Educate development and security teams about the risks of exposing middleware APIs and enforce secure coding and deployment practices. 7. Consider deploying runtime application self-protection (RASP) or endpoint detection and response (EDR) tools to detect and block suspicious command execution attempts at the host level.

Description

Hoverfly is an open source API simulation tool. In versions 1.11.3 and prior, the middleware functionality in Hoverfly is vulnerable to command injection vulnerability at `/api/v2/hoverfly/middleware` endpoint due to insufficient validation and sanitization in user input. The vulnerability exists in the middleware management API endpoint `/api/v2/hoverfly/middleware`. This issue is born due to combination of three code level flaws: Insufficient Input Validation in middleware.go line 94-96; Unsafe Command Execution in local_middleware.go line 14-19; and Immediate Execution During Testing in hoverfly_service.go line 173. This allows an attacker to gain remote code execution (RCE) on any system running the vulnerable Hoverfly service. Since the input is directly passed to system commands without proper checks, an attacker can upload a malicious payload or directly execute arbitrary commands (including reverse shells) on the host server with the privileges of the Hoverfly process. Commit 17e60a9bc78826deb4b782dca1c1abd3dbe60d40 in version 1.12.0 disables the set middleware API by default, and subsequent changes to documentation make users aware of the security changes of exposing the set middleware API.

References

Community reviews

Loading reviews…