Skip to main content
VulnerabilityPublished Updated

CVE-2025-5455: Qt · Improper Input Validation

Affects QtSource CVE Database V5

0

Not known to be exploited · CVSS 8.4 High · fixed in 6.9.1 : patch Qt soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.9.1, 6.8.4, 6.5.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H/R:U/RE:M/U:Clear

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.qtproject/qt to 6.9.1, 6.8.4 or 6.5.9.

Affected software

ProductAffectedFixed in
Mavenorg.qtproject/qtpkg:maven/org.qtproject/qtOther threatsAffected
  • <=5.15.18
  • 6.0.0 <6.5.9
  • 6.6.0 <6.8.4
  • 6.9.0 <6.9.1
Fixed in
  • 6.5.9
  • 6.8.4
  • 6.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in Qt versions 5.15.19, 6.5.9, 6.8.4, and 6.9.1. Users and developers should upgrade affected Qt versions to these fixed releases to remediate the vulnerability. No additional mitigation is indicated by the vendor advisory.

Description

An issue was found in the private API function qDecodeDataUrl() in QtCore, which is used in QTextDocument and QNetworkReply, and, potentially, in user code. If the function was called with malformed data, for example, an URL that contained a "charset" parameter that lacked a value (such as "data:charset,"), and Qt was built with assertions enabled, then it would hit an assertion, resulting in a denial of service (abort). This impacts Qt up to 5.15.18, 6.0.0->6.5.8, 6.6.0->6.8.3 and 6.9.0. This has been fixed in 5.15.19, 6.5.9, 6.8.4 and 6.9.1.

References

Community reviews

Loading reviews…