CVE-2025-59543: chamilo-lms · Cross-site Scripting
Affects chamilo-lmsSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.11.34 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.11.34
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade chamilo-lms and chamilo/chamilo-lms to 1.11.34.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| chamilochamilo-lms | Affected
| Fixed in
|
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade Chamilo LMS to version 1.11.34 or later, where this vulnerability is patched. Until the upgrade can be applied, administrators should restrict the ability to edit course descriptions to only highly trusted users and implement strict input validation and output encoding on user-generated content fields. Employing web application firewalls (WAFs) with rules targeting XSS payloads can provide temporary protection. Regularly audit LMS user roles and permissions to minimize low-privileged users’ ability to inject content. Enable Content Security Policy (CSP) headers to restrict execution of unauthorized scripts in browsers accessing the LMS. Monitor logs for unusual activity, such as unexpected administrative logins or anomalous HTTP requests containing suspicious scripts. Educate users, especially administrators, about the risks of clicking on untrusted links or viewing unverified course content. Finally, maintain an incident response plan to quickly address any detected compromise resulting from this vulnerability.
Description
Chamilo is a learning management system. Prior to version 1.11.34, there is a stored cross-site scripting (XSS) vulnerability. By injecting malicious JavaScript into the course description field, an attacker with a low-privileged account (e.g., trainer) can execute arbitrary JavaScript code in the context of any other user viewing the course information page, including administrators. This allows an attacker to exfiltrate sensitive session cookies or tokens, resulting in account takeover (ATO) of higher-privileged users. This issue has been patched in version 1.11.34.