Skip to main content
CVE-2025-59831VulnerabilityPublished

CVE-2025-59831: snowyu git-commiters.js · Command Injection

Affects snowyu git-commiters.jsSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 0.1.2 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.1% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade snowyu git-commiters.js to 0.1.2.

Affected software

ProductAffectedFixed in
snowyu git-commiters.jsAffected
  • <0.1.2
Fixed in
  • 0.1.2

AI-suggested

European organizations should immediately audit their software dependencies to identify any usage of git-commiters versions prior to 0.1.2. They must upgrade all instances of git-commiters to version 0.1.2 or later, where the vulnerability is patched. For environments where immediate upgrade is not feasible, implement strict input validation and sanitization on any user-supplied parameters passed to git-commiters, avoiding direct shell command concatenation. Employ runtime application self-protection (RASP) or endpoint detection and response (EDR) solutions to monitor for suspicious command execution patterns. Restrict permissions of processes running git-commiters to the minimum necessary, limiting potential damage from exploitation. Incorporate security scanning tools in CI/CD pipelines to detect vulnerable dependencies automatically. Finally, educate development and DevOps teams about the risks of command injection and secure coding practices, emphasizing the importance of using secure APIs for process execution.

Description

git-commiters is a Node.js function module providing committers stats for their git repository. Prior to version 0.1.2, there is a command injection vulnerability in git-commiters. This vulnerability manifests with the library's primary exported API: gitCommiters(options, callback) which allows specifying options such as cwd for current working directory and revisionRange as a revision pointer, such as HEAD. However, the library does not sanitize for user input or practice secure process execution API to separate commands from their arguments and as such, uncontrolled user input is concatenated into command execution. This issue has been patched in version 0.1.2.

References

Community reviews

Loading reviews…