Skip to main content
VulnerabilityPublished

CVE-2025-60012: Apache Livy · Improper Input Validation

Affects Apache LivySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.9.0-incubating when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0-incubating, 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Livy and Apache Software Foundation/org.apache.livy:livy-server to 0.9.0-incubating; org.apache.livy/livy to 0.9.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache LivyAffected
  • >=0.7.0-incubating <0.9.0-incubating
Fixed in
  • 0.9.0-incubating
Mavenorg.apache.livy/livypkg:maven/org.apache.livy/livyOther threatsAffected
  • <0.9.0
Fixed in
  • 0.9.0
MavenApache Software Foundation/org.apache.livy:livy-serverpkg:maven/Apache Software Foundation/org.apache.livy:livy-serverOther threatsAffected
  • >=0.7.0-incubating <0.9.0-incubating
Fixed in
  • 0.9.0-incubating

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-60012, organizations should upgrade Apache Livy to version 0.9.0 or later, where the vulnerability is fixed. Until upgrade is possible, restrict access to Livy’s REST and JDBC interfaces to trusted users and networks only, using network segmentation, firewalls, and access controls. Implement strict authentication and authorization mechanisms to limit who can send Spark configuration parameters through Livy. Monitor Livy logs for unusual or unexpected configuration parameters in requests. Consider deploying Web Application Firewalls (WAFs) or API gateways that can detect and block suspicious payloads targeting configuration inputs. Regularly audit and review user permissions and interface exposure to minimize the attack surface. Additionally, ensure that sensitive files on the server have appropriate filesystem permissions to reduce the impact of unauthorized access. Finally, keep abreast of updates from Apache and apply security patches promptly.

Description

Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

References

Community reviews

Loading reviews…