Skip to main content
VulnerabilityPublished Updated

CVE-2025-60021: Apache bRPC · Command Injection

Affects Apache bRPCSource CVE Database V5

0

Not known to be exploited · 25% EPSS · CVSS 9.8 Critical : upgrade to 1.15.0 as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
25.5% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.15.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache bRPC to 1.15.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache bRPCAffected
  • >=1.11.0 <1.15.0
Fixed in
  • 1.15.0
GitHubapache/brpcpkg:github/apache/brpcOther threatsAffected
  • =1.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-60021, organizations should immediately upgrade Apache bRPC to version 1.15.0, which contains the official fix addressing the command injection vulnerability. If upgrading is not immediately feasible, apply the patch available at https://github.com/apache/brpc/pull/3101 manually to ensure input validation on the extra_options parameter. Additionally, restrict network access to the /pprof/heap endpoint by implementing firewall rules or network segmentation to limit exposure to trusted sources only. Employ runtime application self-protection (RASP) or intrusion detection systems (IDS) to monitor and block suspicious command execution attempts. Conduct thorough audits of systems running vulnerable versions to detect any signs of compromise. Finally, incorporate secure coding practices and input validation checks in custom extensions or integrations with Apache bRPC to prevent similar vulnerabilities.

Description

Remote command injection vulnerability in heap profiler builtin service in Apache bRPC ((all versions < 1.15.0)) on all platforms allows attacker to inject remote command. Root Cause: The bRPC heap profiler built-in service (/pprof/heap) does not validate the user-provided extra_options parameter and executes it as a command-line argument. Attackers can execute remote commands using the extra_options parameter.. Affected scenarios: Use the built-in bRPC heap profiler service to perform jemalloc memory profiling. How to Fix: we provide two methods, you can choose one of them: 1. Upgrade bRPC to version 1.15.0.2. Apply this patch ( https://github.com/apache/brpc/pull/3101 ) manually.

References

Community reviews

Loading reviews…