CVE-2025-62235: Apache Mynewt NimBLE · Authentication Bypass by Spoofing
Affects Apache Mynewt NimBLESource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.9.0 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.0
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade apache/mynewt-nimble to 1.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Mynewt NimBLE | Affected
| Fixed in– |
GitHubapache/mynewt-nimblepkg:github/apache/mynewt-nimbleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade all affected Apache Mynewt NimBLE instances to version 1.9.0 or later, which contains the fix for this vulnerability. Organizations should conduct an inventory of all BLE-enabled devices using NimBLE to identify vulnerable systems. For devices where upgrading NimBLE is not immediately possible, network-level controls such as restricting BLE communication range or implementing BLE device whitelisting can reduce exposure. Monitoring BLE traffic for unusual bonding requests or repeated Security Requests may help detect exploitation attempts. Additionally, organizations should review and strengthen BLE security policies, including enforcing strong pairing methods and regularly auditing device bonds. Collaboration with device manufacturers to ensure timely firmware updates is critical. Finally, integrating BLE security events into centralized logging and SIEM systems can improve incident response capabilities.
Description
Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.