Skip to main content
VulnerabilityPublished

CVE-2025-62504: envoyproxy envoy · Use After Free

Affects envoyproxy envoySource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.33.12 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.33.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade envoyproxy/envoy to 1.33.12.

Affected software

ProductAffectedFixed in
GitHubenvoyproxy/envoypkg:github/envoyproxy/envoyOther threatsAffected
  • <1.33.12
Fixed in
  • 1.33.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Envoy to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 as soon as possible to fully remediate the use-after-free vulnerability.
  2. If immediate upgrade is not feasible, temporarily increase per_connection_buffer_limit_bytes and initial_stream_window_size (for HTTP/2) to reduce the likelihood of triggering the vulnerability, but do not rely on this as a permanent fix.
  3. Similarly, increase per_request_buffer_limit_bytes and request_body_buffer_limit to mitigate risk.
  4. Restrict and audit Lua script execution privileges within Envoy to trusted users and processes to minimize exploitation potential.
  5. Monitor Envoy logs and metrics for unexpected crashes or local replies generated during response phases as indicators of attempted exploitation.
  6. Implement robust incident response and recovery plans to quickly restore services if a denial of service occurs.
  7. Conduct security reviews of Lua scripts modifying response bodies to ensure they do not inadvertently cause oversized responses.
  8. Engage with Envoy community and security advisories for updates and patches.

Description

Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original response headers, leaving dangling references and causing a crash. This results in denial of service. Updating to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 fixes the issue. Increasing per_connection_buffer_limit_bytes (and for HTTP/2 the initial_stream_window_size) or increasing per_request_buffer_limit_bytes / request_body_buffer_limit can reduce the likelihood of triggering the condition but does not correct the underlying memory safety flaw.

References

Community reviews

Loading reviews…