Skip to main content
CVE-2025-64756VulnerabilityPublished Updated

CVE-2025-64756: isaacs node-glob · OS Command Injection

Affects isaacs node-globSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 11.1.0 or 10.5.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.0% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.1.0, 10.5.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade isaacs node-glob to 11.1.0 or 10.5.0.

Affected software

ProductAffectedFixed in
npmnode-globpkg:npm/node-globOther threatsAffected
  • <10.5.0
  • <11.1.0 >=10.2.0
Fixed in
  • 10.5.0
  • 11.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade node-glob to versions 10.5.0 or 11.1.0 or later to ensure the vulnerability is patched. In addition, organizations should audit their CI/CD pipelines and development environments to identify any usage of the vulnerable node-glob versions, especially where the -c/--cmd option is used. Implement strict input validation and sanitization for filenames and any external inputs that influence glob patterns. Avoid passing untrusted filenames directly to shell commands or using shell: true in child process invocations. Employ runtime application self-protection (RASP) or endpoint detection and response (EDR) tools to monitor for unusual command execution patterns. Incorporate security scanning tools in the software supply chain to detect vulnerable dependencies automatically. For critical environments, consider isolating build and deployment systems with strict access controls and network segmentation to limit potential damage from exploitation. Finally, educate developers and DevOps teams about secure usage patterns of node-glob and the risks of shell command injection.

Description

Glob matches files using patterns the shell uses. Starting in version 10.2.0 and prior to versions 10.5.0 and 11.1.0, the glob CLI contains a command injection vulnerability in its -c/--cmd option that allows arbitrary command execution when processing files with malicious names. When glob -c <command> <patterns> are used, matched filenames are passed to a shell with shell: true, enabling shell metacharacters in filenames to trigger command injection and achieve arbitrary code execution under the user or CI account privileges. This issue has been patched in versions 10.5.0 and 11.1.0.

References

Community reviews

Loading reviews…