Skip to main content
CVE-2025-66581VulnerabilityPublished

CVE-2025-66581: frappe lms · Incorrect Authorization

Affects frappe lmsSource CVE Database V5

0

Not known to be exploited · CVSS 1.3 Low : upgrade to 2.41.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
1.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.41.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade frappe/lms to 2.41.0.

Affected software

ProductAffectedFixed in
GitHubfrappe/lmspkg:github/frappe/lmsOther threatsAffected
  • <2.41.0
Fixed in
  • 2.41.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should promptly upgrade all Frappe LMS instances to version 2.41.0 or later to remediate this vulnerability. Until patched, administrators should restrict LMS access to trusted users and monitor for unusual API activity indicative of privilege abuse. Implement network-level access controls to limit exposure of LMS APIs to internal or VPN-only access. Conduct regular audits of user roles and permissions to ensure no unauthorized privilege escalation has occurred. Additionally, review and harden server-side authorization logic in custom LMS extensions or integrations to prevent similar flaws. Employ logging and alerting on sensitive LMS operations to detect potential misuse early. Finally, educate users about the importance of using only official LMS interfaces and discourage direct API manipulation.

Description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to 2.41.0, a flaw in the server-side authorization logic allowed authenticated users to perform actions beyond their assigned roles across multiple features. Because the affected endpoints relied on client-side or UI-level checks instead of enforcing permissions on the server, users with low-privileged roles (such as students) could perform operations intended only for instructors or administrators via directly using the API's. This vulnerability is fixed in 2.41.0.

References

Community reviews

Loading reviews…