CVE-2025-67859: https://github.com/linrunner TLP · Improper Authentication
Affects https://github.com/linrunner TLPSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.9.1 when convenient.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade https://github.com/linrunner TLP to 1.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| https://github.com/linrunnerTLP | Affected
| Fixed in
|
GitHublinrunner/tlppkg:github/linrunner/tlpOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade TLP to version 1.9.1 or later as soon as the patch is released to ensure the authentication flaw is corrected.
- Restrict local user access on Linux systems running TLP to trusted personnel only, minimizing the risk of unauthorized configuration changes.
- Implement strict file system permissions and access controls on TLP configuration files and daemon interfaces to prevent unauthorized modifications.
- Monitor system logs and power profile changes for unusual activity that could indicate exploitation attempts.
- Use Linux security modules (e.g., SELinux, AppArmor) to enforce additional access restrictions on TLP processes and configuration files.
- Incorporate TLP configuration and log integrity checks into regular security audits and endpoint monitoring.
- Educate system administrators and users about the risks of local privilege escalation and the importance of maintaining strict local access controls.
Description
A Improper Authentication vulnerability in TLP allows local users to arbitrarily control the power profile in use as well as the daemon’s log settings.This issue affects TLP: from 1.9 before 1.9.1.