Skip to main content
VulnerabilityPublished

CVE-2025-68702: samrocketman jervis · Weak Cryptography

Affects samrocketman jervisSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 2.2 soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jervis and samrocketman/jervis to 2.2.

Affected software

ProductAffectedFixed in
samrocketmanjervisAffected
  • <2.2
Fixed in
  • 2.2
GitHubsamrocketman/jervispkg:github/samrocketman/jervisOther threatsAffected
  • <2.2
Fixed in
  • 2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all instances of the Jervis library to version 2.2 or later to remediate the vulnerability. In addition to upgrading, organizations should audit their Jenkins pipeline scripts and Job DSL configurations for any signs of tampering or anomalies that could indicate exploitation attempts. Implement strict access controls and monitoring on Jenkins environments to detect unauthorized changes. Employ cryptographic verification of pipeline scripts and artifacts where possible to ensure integrity. Regularly review and update CI/CD toolchains to incorporate security patches promptly. Consider isolating Jenkins environments and limiting network exposure to reduce attack surface. Finally, integrate security scanning tools that can detect usage of vulnerable Jervis versions and enforce compliance with secure software supply chain practices.

Description

CVE-2025-68702 is a high-severity vulnerability in the samrocketman Jervis library, used for Job DSL plugin scripts and Jenkins shared pipeline libraries. The issue arises from incorrect padding in cryptographic operations where padLeft(32, '0') is used instead of padLeft(64, '0') to handle SHA-256 hashes, which are 32 bytes or 64 hex characters long. This improper padding leads to the use of a broken or risky cryptographic algorithm (CWE-327), potentially weakening the security of cryptographic functions within affected Jenkins pipelines. The vulnerability affects all Jervis versions prior to 2.2 and does not require authentication or user interaction to exploit, with a CVSS 4.0 score of 8.7 indicating high severity. Although no known exploits are currently in the wild, the flaw could allow attackers to compromise the integrity of pipeline scripts or related secrets. The issue is fixed in version 2.2 of Jervis.

References

Community reviews

Loading reviews…