Skip to main content
VulnerabilityPublished

CVE-2025-69219: Apache Airflow Providers Http · Improper Control of Dynamically-Managed Code Resources

Affects Apache Airflow Providers HttpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 6.0.0 soon.

Data as of 30 Oct 2026, 11:34 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade Apache Airflow Providers Http to 6.0.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Airflow Providers HttpAffected
  • >=5.1.0 <6.0.0
Fixed in
  • 6.0.0
PyPIapache-airflow-providers-httppkg:pypi/apache-airflow-providers-httpOther threatsAffected
  • =5.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-69219, organizations should: 1) Immediately upgrade Apache Airflow Providers Http to version 6.0.0 or later, which includes patches that enforce proper control over dynamically-managed code resources and sanitize database inputs. 2) Restrict and monitor database access rigorously, ensuring only trusted administrators and services have direct DB permissions, and avoid direct DB modifications outside of Airflow's API. 3) Implement strong authentication and authorization controls around the Airflow metadata database to prevent unauthorized access. 4) Employ network segmentation and firewall rules to limit access to the Airflow database server. 5) Audit Airflow logs and database activity for unusual or unauthorized changes indicative of exploitation attempts. 6) Regularly review and update Airflow deployment security best practices, including least privilege principles and secure configuration management. 7) Consider deploying runtime application self-protection (RASP) or endpoint detection solutions to detect anomalous code execution within Airflow components. These measures collectively reduce the risk of exploitation and limit potential damage if an attacker gains database access.

Description

CVE-2025-69219 is a high-severity vulnerability in Apache Airflow Providers Http version 5.1.0 that allows a user with database access to execute arbitrary code on the Triggerer component. This flaw arises from improper control of dynamically-managed code resources (CWE-913), enabling an attacker with DB access to gain permissions equivalent to a DAG author. Although direct database access is uncommon and not recommended in Airflow deployments, exploitation could lead to full compromise of workflow execution privileges. The vulnerability has a CVSS score of 8.8, reflecting its critical impact on confidentiality, integrity, and availability without requiring user interaction. Upgrading to version 6.0.0 of the provider is advised to mitigate this risk.

References

Community reviews

Loading reviews…