Skip to main content
CVE-2025-8944VulnerabilityPublished

CVE-2025-8944: OceanWP (WordPress theme) · Incorrect Authorization

Affects OceanWP (WordPress theme)Source CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
OceanWPAffected
  • =0
Fixed in–

AI-suggested

To mitigate this vulnerability, European organizations should promptly update the OceanWP theme to version 4.1.2 or later once available. Until then, administrators should restrict user roles and capabilities carefully, minimizing the number of users with authenticated access, especially subscriber or similar low-privilege accounts. Implementing strict user role audits and removing unnecessary accounts can reduce the attack surface. Additionally, monitoring AJAX requests and theme option changes via web application firewalls (WAFs) or security plugins can help detect suspicious activity. Organizations should also consider disabling AJAX handlers related to theme option updates if feasible or applying custom patches that enforce capability checks on these handlers. Regular backups of website configurations and themes will facilitate recovery if unauthorized changes occur. Finally, educating users about the risks of unauthorized access and enforcing strong authentication mechanisms (e.g., MFA) will further reduce exploitation chances.

Description

The OceanWP WordPress theme before 4.1.2 is vulnerable to an option update due to a missing capability check on one of its AJAX request handler, allowing any authenticated users, such as subscriber to update the darkMod` setting.

References

Community reviews

Loading reviews…