CVE-2025-9910: jsondiffpatch · Cross-site Scripting (XSS)
Affects jsondiffpatchSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jsondiffpatch | Affected
| Fixed in– |
AI-suggested
European organizations should upgrade jsondiffpatch to version 0.7.2 or later, where this vulnerability is fixed. If immediate upgrade is not feasible, implement strict input validation and sanitization on all JSON data before performing diff operations and rendering HTML output. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in the web application context. Additionally, avoid rendering diffs of untrusted or user-supplied JSON data in HTML format or use alternative rendering methods that do not involve HTML output. Conduct thorough code reviews and security testing focusing on XSS vectors in any custom usage of jsondiffpatch. Monitoring web application logs for unusual script injection attempts and educating developers about secure handling of JSON diff rendering can further reduce risk.
Description
Versions of the package jsondiffpatch before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin. An attacker can inject malicious scripts into HTML payloads that may lead to code execution if untrusted payloads were used as source for the diff, and the result renderer using the built-in html formatter on a private website.
References
- security.snyk.io/vuln/SNYK-JS-JSONDIFFPATCH-10369031 (opens in a new tab)
- security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-12549276 (opens in a new tab)
- security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-12549277 (opens in a new tab)
- github.com/benjamine/jsondiffpatch/commit/0e374b5dd8d7879b329a9fc18affbd46ad50dd14 (opens in a new tab)
- github.com/benjamine/jsondiffpatch/issues/383 (opens in a new tab)
- benjamine.github.io/jsondiffpatch/index.html (opens in a new tab)