Skip to main content
VulnerabilityPublished

CVE-2026-10531: AI Share & Summarize (WordPress plugin) · Cross-Site Scripting (XSS)

Affects AI Share & Summarize (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 2.0.4 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade AI Share & Summarize (WordPress plugin) to 2.0.4.

Affected software

ProductAffectedFixed in
AI Share & SummarizeAffected
  • <2.0.4
Fixed in
  • 2.0.4

AI-suggested

If you cannot patch yet, restrict Contributor or higher user roles to trusted users only and consider disabling or removing the plugin if possible.

Description

The AI Share & Summarize WordPress plugin before 2.0.4 does not sanitise and escape some of its shortcode attributes before outputting them in a page, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.

References

Community reviews

Loading reviews…