Skip to main content
VulnerabilityPublished

CVE-2026-114527: Drupal UI Icons · Cross-site Scripting

Affects Drupal UI IconsSource CVE Database V5

0
Compare

Not known to be exploited : upgrade to 2.0.2 or 1.1.3 soon.

Data as of 30 Oct 2026, 04:14 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 2.0.2, 1.1.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Drupal UI Icons to 2.0.2 or 1.1.3.

Affected software

ProductAffectedFixed in
DrupalUI IconsAffected
  • >=2.0.0 <2.0.2
Fixed in
  • 2.0.2
DrupalUI IconsAffected
  • <1.1.3
Fixed in
  • 1.1.3

AI-suggested

Upgrade Drupal UI Icons to version 1.1.3 or later if using the 1.x branch, or to version 2.0.2 or later if using the 2.x branch. These versions contain the official fixes for this XSS vulnerability.

Description

CVE-2026-114527 is a Cross-site Scripting (XSS) vulnerability in the Drupal UI Icons component. It affects UI Icons versions from 0.0.0 up to but not including 1.1.3, and from 2.0.0 up to but not including 2.0.2. The vulnerability arises from improper neutralization of input during web page generation, allowing injection of malicious scripts. Fixed versions are 1.1.3 and 2.0.2.

References

Community reviews

Loading reviews…