Skip to main content
VulnerabilityPublished

CVE-2026-2349: Drupal UI Icons · Cross-site Scripting

Affects Drupal UI IconsSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.1.1 or 1.0.1 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.1, 1.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Drupal UI Icons to 1.1.1 or 1.0.1.

Affected software

ProductAffectedFixed in
DrupalUI IconsAffected
  • >=1.1.0 <1.1.1
Fixed in
  • 1.1.1
DrupalUI IconsAffected
  • <1.0.1
Fixed in
  • 1.0.1

AI-suggested

To mitigate CVE-2026-2349, organizations should immediately upgrade the Drupal UI Icons component to versions 1.0.1 or later, or 1.1.1 or later, where the vulnerability is addressed. In the absence of official patches, administrators should implement strict input validation and sanitization on all user-supplied data, especially in UI elements rendering icons or dynamic content. Deploying Content Security Policy (CSP) headers can help restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Web Application Firewalls (WAFs) should be configured to detect and block suspicious payloads targeting UI Icons. Regular security audits and penetration testing focusing on XSS vectors are recommended. Additionally, educating developers and content managers about secure coding practices and the risks of injecting untrusted input into web pages can prevent similar issues. Monitoring Drupal security advisories and subscribing to vulnerability feeds will ensure timely awareness of patches and exploits.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal UI Icons allows Cross-Site Scripting (XSS).This issue affects UI Icons: from 0.0.0 before 1.0.1, from 1.1.0 before 1.1.1.

References

Community reviews

Loading reviews…