CVE-2026-114532: Drupal UI Icons · Cross-site Scripting
Affects Drupal UI IconsSource CVE Database V5
Not known to be exploited : upgrade to 2.0.2 or 1.1.3 soon.
Data as of 30 Oct 2026, 04:02 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 2.0.2, 1.1.3
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal UI Icons to 2.0.2 or 1.1.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalUI Icons | Affected
| Fixed in
|
| DrupalUI Icons | Affected
| Fixed in
|
AI-suggested
Users should upgrade Drupal UI Icons to version 1.1.3 or later, or 2.0.2 or later, where this vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-114532 is a Cross-Site Scripting (XSS) vulnerability in the Drupal UI Icons component. It affects UI Icons versions from 0.0.0 up to but not including 1.1.3, and from 2.0.0 up to but not including 2.0.2. The vulnerability arises from improper neutralization of input during web page generation, allowing injection of malicious scripts. Fixed versions 1.1.3 and 2.0.2 address this issue.