CVE-2026-114531: Drupal Swiper formatter · Cross-site Scripting
Affects Drupal Swiper formatterSource CVE Database V5
Not known to be exploited : upgrade to 3.1.0 or 2.1.2 soon.
Data as of 30 Oct 2026, 04:02 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 3.1.0, 2.1.2
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal Swiper formatter to 3.1.0 or 2.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalSwiper formatter | Affected
| Fixed in
|
| DrupalSwiper formatter | Affected
| Fixed in
|
AI-suggested
Update the Drupal Swiper formatter module to version 2.1.2 or later if using the 2.x branch, or to version 3.1.0 or later if using the 3.x branch. These versions contain the official fixes for this stored XSS vulnerability.
Description
CVE-2026-114531 is a stored cross-site scripting (XSS) vulnerability in the Drupal Swiper formatter module. It affects versions from 0.0.0 up to but not including 2.1.2, and from 3.0.1 up to but not including 3.1.0. The vulnerability arises from improper neutralization of input during web page generation, allowing attackers to inject malicious scripts that are stored and executed in users' browsers.