Skip to main content
VulnerabilityPublished

CVE-2026-116796: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 13.1.1 : patch highcharts soon.

Data as of 28 Oct 2026, 17:44 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.1.1, 12.6.2, 11.4.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts and highcharts/highcharts to 13.1.1, 12.6.2 or 11.4.9.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • >=13.0.0 <13.1.1
Fixed in
  • 13.1.1
highchartshighchartsAffected
  • >=12.0.0 <12.6.2
Fixed in
  • 12.6.2
highchartshighchartsAffected
  • >=10.3.2 <11.4.9
Fixed in
  • 11.4.9
npmhighcharts/highchartspkg:npm/highcharts/highchartsOther threatsAffected
  • >=10.3.2 <11.4.9
  • >=12.0.0 <12.6.2
  • >=13.0.0 <13.1.1
Fixed in
  • 11.4.9
  • 12.6.2
  • 13.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Highcharts versions 11.4.9, 12.6.2, and 13.1.1. Users should upgrade to one of these fixed versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

Highcharts JS versions from 10.3.2 up to but not including 11.4.9, 12.0.0 up to 12.6.2, and 13.0.0 up to 13.1.1 contain a cross-site scripting (XSS) vulnerability. This occurs because the SVG anchor xlink:href attribute does not enforce the allowed-scheme check that is applied to href and src attributes. An attacker controlling chart text options can embed a javascript URL that executes script when the exported or server-rendered SVG is parsed and the link is activated. The issue is fixed in versions 11.4.9, 12.6.2, and 13.1.1.

References

Community reviews

Loading reviews…