CVE-2026-118242: highcharts · Cross-site Scripting
Affects highchartsSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 13.1.0 soon.
Data as of 28 Oct 2026, 17:57 UTC
- Patch
- Available – fixed in 13.1.0, 3.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade highcharts to 13.1.0; grid-lite and grid-pro and highcharts/highcharts to 3.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| highchartshighcharts | Affected
| Fixed in
|
| @highchartsgrid-lite | Affected
| Fixed in
|
| @highchartsgrid-pro | Affected
| Fixed in
|
GitHubhighcharts/highchartspkg:github/highcharts/highchartsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Highcharts to version 3.2.0 or later, including 13.1.0 where the issue is fixed. No other mitigation is indicated by the vendor advisory. Users should ensure they are not using affected versions to prevent exploitation.
Description
CVE-2026-118242 is a high-severity cross-site scripting (XSS) vulnerability in Highcharts JS versions from 2.3.0 up to but not including 3.2.0. The flaw arises because Highcharts Grid creates SVG path elements from icon definitions and copies child keys with setAttribute, allowing an attacker controlling the Grid configuration to inject event-handler attributes. This enables script execution in the context of the hosting page when users interact with the malicious icons. The issue is fixed in version 3.2.0 and later.