Skip to main content
VulnerabilityPublished

CVE-2026-118245: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 13.1.0 soon.

Data as of 28 Oct 2026, 18:12 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.1.0, 4.2.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts to 13.1.0; dashboards to 4.2.3; highcharts/highcharts to 13.1.0 or 4.2.3.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • <13.1.0
Fixed in
  • 13.1.0
@highchartsdashboardsAffected
  • >=1.0.0 <4.2.3
Fixed in
  • 4.2.3
GitHubhighcharts/highchartspkg:github/highcharts/highchartsOther threatsAffected
  • <4.2.3
  • >=1.0.0 <4.2.3
  • <13.1.0
Fixed in
  • 4.2.3
  • 13.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Highcharts JS to version 4.2.3 or later, or 13.1.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.

Description

Highcharts JS versions from 1.0.0 up to but not including 4.2.3 contain a cross-site scripting (XSS) vulnerability in the Highcharts Dashboards feature. The issue arises because the dashboard uses an unchecked property lookup to invoke chart constructors, allowing an attacker controlling dashboard configuration to execute arbitrary markup and event handlers in the hosting page without user interaction. This vulnerability is fixed in versions 4.2.3 and 13.1.0.

References

Community reviews

Loading reviews…