Skip to main content
VulnerabilityPublished

CVE-2026-118246: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 8.4 High · fixed in 13.1.1 : patch highcharts soon.

Data as of 28 Oct 2026, 18:12 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.1.1, 12.6.1, 11.4.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts to 13.1.1, 12.6.1 or 11.4.9.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • >=13.0.0 <13.1.1
Fixed in
  • 13.1.1
highchartshighchartsAffected
  • >=12.0.0 <12.6.1
Fixed in
  • 12.6.1
highchartshighchartsAffected
  • >=10.0.0 <11.4.9
Fixed in
  • 11.4.9
npmhighcharts/highchartspkg:npm/highcharts/highchartsOther threatsAffected
  • >=10.0.0 <=11.4.8
  • >=12.0.0 <=12.6.0
  • >=13.0.0 <=13.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Highcharts to version 11.4.9, 12.6.1, or 13.1.1 or later, where this vulnerability is fixed. Users of styled-mode charts are not affected by this issue. No other mitigations are specified by the vendor advisory.

Description

Highcharts JS versions from 10.0.0 up to but not including 11.4.9, 12.0.0 up to but not including 12.6.1, and 13.0.0 up to but not including 13.1.1 are vulnerable to a cross-site scripting (XSS) issue. The vulnerability arises because Highcharts applies breadcrumbs.style as SVG attributes without filtering attribute names, allowing attackers controlling chart configuration to inject event-handler keys. This leads to execution of malicious scripts in the context of the hosting page when users interact with breadcrumb buttons. Styled-mode charts are not affected. The issue is fixed in versions 11.4.9, 12.6.1, and 13.1.1.

References

Community reviews

Loading reviews…