CVE-2026-120550: WP User Manager – Registration Form, Login Form, User Profile Builder & Member Directory · Cross-site Scripting
Affects WP User Manager – Registration Form, Login Form, User Profile Builder & Member DirectorySource CVE Database V5
Not known to be exploited · CVSS 6.4 Medium.
Data as of 6 Nov 2026, 09:50 UTC
Thin evidence
One scorer or none| CNA (Wordfence) | CVSS 3.1 | 6.4 |
|---|
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpusermanagerWP User Manager – Registration Form, Login Form, User Profile Builder & Member Directory | Affected
| Fixed in– |
AI-suggested
Users should upgrade beyond version 2.10.2 once a fixed version is released. Until then, restrict subscriber-level access where possible and monitor for suspicious activity. Because the vulnerability involves REST API input sanitization bypass, disabling or restricting access to the REST users endpoint may mitigate risk. Check the vendor advisory for updates on patch availability.
Description
The WP User Manager plugin for WordPress versions up to and including 2.10.2 contains a stored cross-site scripting (XSS) vulnerability. This flaw arises from insufficient input sanitization and output escaping of the 'name' parameter via the REST users endpoint, allowing authenticated users with subscriber-level access or higher to inject malicious scripts. The vulnerability is exploitable through the WordPress core REST endpoint, bypassing the plugin's front-end sanitization. This can lead to script execution when other users access the injected pages.
References
- wordfence.com/threat-intel/vulnerabilities/id/3e9da4a7-89ba-426c-943a-e7bc79a04d7c?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-user-manager/tags/2.10.2/includes/fields/types/class-wpum-field-dropdown.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-user-manager/tags/2.10.2/includes/fields/class-wpum-field.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-user-manager/tags/2.10.2/templates/profiles/about.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-user-manager/tags/2.10.2/includes/fields/wpum-fields-functions.php (opens in a new tab)
- downloads.wordpress.org/plugin/wp-user-manager.2.10.3.zip (opens in a new tab)