CVE-2026-16954: AI Engine (WordPress plugin) · Information Exposure
Affects AI Engine (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.6.4 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.6.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade AI Engine (WordPress plugin) to 3.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AI Engine | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict Editor role permissions or limit access to the affected admin pages to trusted users only.
Description
CVE-2026-16954 is an information exposure vulnerability in the AI Engine WordPress plugin versions before 3.6.4. It allows users with the Editor role to access secret configuration values, such as third-party API keys and authentication tokens, in cleartext via an admin page's inline script data. These secrets are normally restricted to administrators. The vulnerability has a CVSS score of 6.5, indicating a medium severity level.