Skip to main content
VulnerabilityPublished

CVE-2026-20757: Gallagher Command Centre Server · Improper Locking

Affects Gallagher Command Centre ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.5 Low.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
2.5Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.07% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GallagherCommand Centre ServerAffected
  • 9.10 – 9.40
  • <=9.00
4 affected builds
Fixed in–

AI-suggested

To mitigate CVE-2026-20757, organizations should promptly upgrade Gallagher Command Centre Server installations to the fixed versions: vEL9.40.1976(MR1) or later for 9.40, vEL9.30.3382(MR4) or later for 9.30, vEL9.20.3783(MR6) or later for 9.20, vEL9.10.4647(MR9) or later for 9.10, or any version later than 9.00. Since the vulnerability requires local privileged access, enforcing strict access controls and monitoring for unauthorized privilege escalations can reduce the risk of exploitation. Implementing robust internal network segmentation and limiting administrative access to trusted personnel will further reduce exposure. Regularly auditing system logs for unusual activity related to the Command Centre Server and Morpho integration components can help detect attempted exploitation. Additionally, Gallagher customers should subscribe to vendor advisories to receive timely updates and patches. Testing patches in a controlled environment before deployment is recommended to ensure compatibility and stability.

Description

Improper Locking vulnerability (CWE-667) in Gallagher Morpho integration allows a privileged operator to cause a limited denial-of-service in the Command Centre Server. This issue affects Command Centre Server: 9.40 prior to vEL9.40.1976(MR1), 9.30 prior to vEL9.30.3382 (MR4), 9.20 prior to vEL9.20.3783 (MR6), 9.10 prior to vEL9.10.4647 (MR9), all versions of 9.00 and prior.

References

Community reviews

Loading reviews…