CVE-2026-22183: wpDiscuz (WordPress plugin) · Cross-site Scripting
Affects wpDiscuz (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 7.6.47 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.6.47
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade wpDiscuz (WordPress plugin) to 7.6.47.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gVectorswpDiscuz | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade wpDiscuz to version 7.6.47 or later once available, as this will contain the necessary patches to properly escape user input in AJAX responses. If you cannot patch yet, restrict the unfiltered_html capability to the minimum number of trusted users, ideally only site administrators, to reduce the risk of malicious comment injection. Implement additional input validation and output encoding on comment content at the application level if possible. Employ Web Application Firewalls (WAFs) with rules to detect and block suspicious script injections in comment submissions and AJAX responses. Regularly audit user roles and permissions to ensure no unnecessary privileges are granted. Monitor logs for unusual comment activity or AJAX requests that may indicate exploitation attempts. Educate content moderators and administrators about the risks of granting unfiltered_html capabilities. Consider disabling inline comment previews if they are not essential to reduce attack surface.
Description
CVE-2026-22183 is a stored cross-site scripting (XSS) vulnerability in the wpDiscuz WordPress plugin before version 7.6.47. It affects the inline comment preview functionality, allowing authenticated users with unfiltered_html capabilities to inject malicious JavaScript via comment content. The vulnerability arises because the getLastInlineComments() function in class. WpdiscuzHelperAjax.php does not properly escape HTML in AJAX responses. Exploitation requires user interaction and privileges to submit comments with unescaped content. The CVSS 4.0 base score is 5.