Skip to main content
VulnerabilityPublished

CVE-2026-23489: pluginsGLPI fields · Improper Input Validation

Affects pluginsGLPI fieldsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.23.3 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.23.3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade fields and pluginsglpi/fields to 1.23.3.

Affected software

ProductAffectedFixed in
pluginsGLPIfieldsAffected
  • <1.23.3
Fixed in
  • 1.23.3
GitHubpluginsglpi/fieldspkg:github/pluginsglpi/fieldsOther threatsAffected
  • <1.23.3
Fixed in
  • 1.23.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-23489, organizations should immediately upgrade the 'fields' plugin to version 1.23.3 or later, where the vulnerability has been patched. In addition to patching, organizations should audit user permissions to ensure that only trusted and necessary users have the ability to create dropdowns or manage plugin configurations. Implement strict role-based access controls (RBAC) and regularly review user privileges to minimize the risk of insider threats or compromised accounts. Employ web application firewalls (WAFs) with rules designed to detect and block suspicious PHP code injection attempts. Monitor logs for unusual activity related to plugin usage or PHP execution. Where possible, isolate GLPI servers within segmented network zones to limit potential lateral movement. Finally, maintain regular backups of GLPI data and configurations to enable rapid recovery in case of compromise.

Description

Fields is a GLPI plugin that allows users to add custom fields on GLPI items forms. Prior to version 1.23.3, it is possible to execute arbitrary PHP code from users that are allowed to create dropdowns. This issue has been patched in version 1.23.3.

References

Community reviews

Loading reviews…