Skip to main content
VulnerabilityPublished

CVE-2026-23887: Intermesh groupoffice · Cross-site Scripting

Affects Intermesh groupofficeSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 25.0.80 or 6.8.149 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.0.80, 6.8.149
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade groupoffice to 25.0.80 or 6.8.149; intermesh/groupoffice to 6.8.149.

Affected software

ProductAffectedFixed in
IntermeshgroupofficeAffected
  • >=25.0.1 <25.0.80
Fixed in
  • 25.0.80
IntermeshgroupofficeAffected
  • <6.8.149
Fixed in
  • 6.8.149
GitHubintermesh/groupofficepkg:github/intermesh/groupofficeOther threatsAffected
  • <6.8.149
Fixed in
  • 6.8.149

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Group-Office installations to version 6.8.149 or 25.0.80 and above immediately to apply the official fix.
  2. Implement strict input validation and sanitization on all user-supplied filenames and other inputs to prevent injection of malicious scripts.
  3. Deploy Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts within the Group-Office web application context.
  4. Educate users on the risks of interacting with suspicious filenames or links within the application to reduce the likelihood of triggering malicious payloads.
  5. Monitor application logs and user activity for unusual behavior indicative of exploitation attempts.
  6. Consider isolating or sandboxing file viewing components to limit the impact of potential XSS attacks.
  7. Regularly review and update web application firewall (WAF) rules to detect and block XSS payloads targeting Group-Office.
  8. Conduct periodic security assessments and penetration testing focusing on input validation and XSS vulnerabilities in the Group-Office environment.

Description

CVE-2026-23887 is a stored Cross-Site Scripting (XSS) vulnerability in Intermesh Group-Office versions prior to 6.8.149 and between 25.0.1 and 25.0.79. It arises from unsanitized filenames stored in the database, which when viewed by users, can execute malicious scripts in their browsers. This vulnerability can lead to session hijacking or unauthorized actions within the Group-Office web interface. The issue is limited to the file-viewing context and requires user interaction to trigger.

References

Community reviews

Loading reviews…