Skip to main content
VulnerabilityPublished

CVE-2026-24672: gunet openeclass · Cross-site Scripting

Affects gunet openeclassSource CVE Database V5

0

Not known to be exploited · CVSS 7.3 High : upgrade to 4.2 soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openeclass and gunet/openeclass to 4.2.

Affected software

ProductAffectedFixed in
gunetopeneclassAffected
  • <4.2
Fixed in
  • 4.2
GitHubgunet/openeclasspkg:github/gunet/openeclassOther threatsAffected
  • <4.2
Fixed in
  • 4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate upgrade of all Open eClass installations to version 4.2 or later, where the vulnerability is patched.
  2. Implement strict input validation and output encoding on all user profile fields to prevent injection of malicious scripts.
  3. Conduct regular security audits and code reviews focusing on input handling and sanitization in web applications.
  4. Educate users and administrators about the risks of XSS and encourage cautious behavior when interacting with user-generated content.
  5. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers.
  6. Monitor logs and user activities for unusual behavior that may indicate exploitation attempts.
  7. Restrict profile editing permissions to trusted users where possible to reduce the risk of malicious input.
  8. Ensure that multi-factor authentication is enabled to mitigate the impact of credential theft.
  9. Maintain an incident response plan specifically addressing web application attacks like XSS.
  10. Engage with the Open eClass community or vendor for timely updates and security advisories.

Description

CVE-2026-24672 is a high-severity Stored Cross-Site Scripting (XSS) vulnerability in the Open eClass platform versions prior to 4.2. Authenticated students can inject malicious JavaScript into user profile fields, which executes when other users with viewing privileges access the affected pages. This vulnerability can lead to the compromise of user confidentiality and integrity, such as session hijacking or unauthorized actions on behalf of users. The vulnerability requires authentication and user interaction (viewing the affected profile pages) but does not impact availability. The issue has been patched in version 4.2, and no known exploits are currently reported in the wild. European educational institutions using Open eClass versions below 4.2 are at risk, especially in countries with widespread adoption of this platform. Mitigation involves upgrading to version 4.

References

Community reviews

Loading reviews…