Skip to main content
CVE-2026-24740VulnerabilityPublished Updated

CVE-2026-24740: amir20 dozzle · Improper Access Control

Affects amir20 dozzleSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 9.0.3 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade dozzle and amir20/dozzle to 9.0.3.

Affected software

ProductAffectedFixed in
amir20dozzleAffected
  • <9.0.3
Fixed in
  • 9.0.3
GitHubamir20/dozzlepkg:github/amir20/dozzleOther threatsAffected
  • <9.0.3
Fixed in
  • 9.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade Dozzle to version 9.0.3 or later immediately to apply the official patch that enforces proper access control on shell endpoints. 2. Review and tighten container label policies to ensure minimal privileges are granted and labels accurately reflect access boundaries. 3. Implement network segmentation and firewall rules to restrict access to Dozzle’s agent endpoints only to trusted users and systems. 4. Monitor container shell access logs and audit trails for unusual or unauthorized interactive shell sessions, especially those targeting containers outside expected label scopes. 5. Employ container security tools that enforce runtime policies and detect privilege escalation attempts within containers. 6. Educate DevOps and security teams about the risks of improper access control in container management tools and encourage regular vulnerability scanning and patching. 7. Consider isolating critical containers on separate hosts or using additional container security layers to limit the impact of potential breaches.

Description

CVE-2026-24740 is a high-severity improper access control vulnerability in Dozzle, a realtime log viewer for Docker containers. Versions prior to 9.0.3 allow users restricted by label filters to bypass these restrictions and obtain an interactive root shell in containers outside their authorized scope by directly targeting container IDs. This flaw enables privilege escalation within the same host, potentially compromising container integrity and confidentiality. The vulnerability requires no user interaction and can be exploited remotely over the network with low complexity. Although no known exploits are currently in the wild, affected users should upgrade to Dozzle 9.0.3 immediately to mitigate risk. European organizations using Dozzle in containerized environments are at risk, especially those with multi-tenant or segmented container deployments.

References

Community reviews

Loading reviews…