Skip to main content
VulnerabilityPublished

CVE-2026-25490: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2
craftcmscommerceAffected
  • >=4.0.0-RC1 <4.10.1
Fixed in
  • 4.10.1
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately verify their Craft Commerce versions and upgrade to 4.10.1 or 5.5.2 or later to apply the official patches. Beyond patching, organizations should implement strict input validation and sanitization controls on all user-supplied data fields, especially those accessible by administrative users. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts within the admin panel. Regularly audit user permissions to ensure that only trusted personnel have high-level access capable of injecting data into inventory fields. Monitor administrative interfaces for unusual activity or unexpected changes in inventory data. Consider implementing web application firewalls (WAFs) with rules to detect and block common XSS payloads targeting the admin panel. Finally, conduct security awareness training for administrators to recognize suspicious behavior and potential social engineering attempts that could lead to privilege escalation.

Description

Craft Commerce is an ecommerce platform for Craft CMS. In versions from 4.0.0-RC1 to 4.10.0 and from 5.0.0 to 5.5.1, a stored XSS vulnerability in Craft Commerce allows attackers to execute malicious JavaScript in an administrator’s browser. This occurs because the 'Address Line 1' field in Inventory Locations is not properly sanitized before being displayed in the admin panel. This issue has been patched in versions 4.10.1 and 5.5.2.

References

Community reviews

Loading reviews…