Skip to main content
VulnerabilityPublished

CVE-2026-2687: Reading progressbar (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Reading progressbar (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 1.3.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Reading progressbar (WordPress plugin) to 1.3.1.

Affected software

ProductAffectedFixed in
Reading progressbarAffected
  • <1.3.1
Fixed in
  • 1.3.1

AI-suggested

To mitigate CVE-2026-2687, organizations should immediately update the Reading progressbar plugin to version 1.3.1 or later once the patch is released. If you cannot patch yet, administrators should restrict plugin configuration access strictly to trusted users and audit admin accounts for suspicious activity. Implementing a Web Application Firewall (WAF) with custom rules to detect and block suspicious script injections in plugin settings can provide temporary protection. Additionally, enforcing the principle of least privilege by limiting the number of users with administrative rights reduces the risk of exploitation. Regularly scanning WordPress installations with vulnerability scanners such as WPScan can help identify vulnerable plugins. Site administrators should also monitor logs for unusual behavior indicative of XSS exploitation attempts. Finally, educating administrators about the risks of stored XSS and safe plugin management practices will help reduce the likelihood of successful attacks.

Description

The Reading progressbar WordPress plugin before 1.3.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

References

Community reviews

Loading reviews…