Skip to main content
VulnerabilityPublished

CVE-2026-27613: maximmasiutin TinyWeb · OS Command Injection

Affects maximmasiutin TinyWebSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 2.01 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.01
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade TinyWeb and maximmasiutin/TinyWeb to 2.01.

Affected software

ProductAffectedFixed in
maximmasiutinTinyWebAffected
  • <2.01
Fixed in
  • 2.01
GitHubmaximmasiutin/TinyWebpkg:github/maximmasiutin/TinyWebOther threatsAffected
  • <2.01
Fixed in
  • 2.01

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade TinyWeb to version 2.01 or later immediately to apply the official patch addressing this vulnerability.
  2. If immediate upgrade is not feasible, ensure the STRICT_CGI_PARAMS directive is enabled in the server configuration (it is enabled by default in define.inc) to enforce stricter validation of CGI parameters.
  3. Avoid using CGI executables that accept dangerous command-line flags, such as php-cgi.exe, or replace them with safer alternatives that do not expose such attack vectors.
  4. Deploy a Web Application Firewall (WAF) in front of the TinyWeb server configured to block URL query string parameters that begin with a hyphen (-) or contain encoded double quotes (%22), as these are commonly used in exploitation attempts.
  5. Conduct thorough auditing and monitoring of web server logs for suspicious CGI parameter usage or unusual command-line flags.
  6. Restrict permissions of the web server process to the minimum necessary to limit potential damage from exploitation.
  7. Regularly review and update server configurations and security policies to incorporate emerging threat intelligence related to CGI and web server vulnerabilities.

Description

TinyWeb is a web server (HTTP, HTTPS) written in Delphi for Win32. A vulnerability in versions prior to 2.01 allows unauthenticated remote attackers to bypass the web server's CGI parameter security controls. Depending on the server configuration and the specific CGI executable in use, the impact is either source code disclosure or remote code execution (RCE). Anyone hosting CGI scripts (particularly interpreted languages like PHP) using vulnerable versions of TinyWeb is impacted. The problem has been patched in version 2.01. If upgrading is not immediately possible, ensure `STRICT_CGI_PARAMS` is enabled (it is defined by default in `define.inc`) and/or do not use CGI executables that natively accept dangerous command-line flags (such as `php-cgi.exe`). If hosting PHP, consider placing the server behind a Web Application Firewall (WAF) that explicitly blocks URL query string parameters that begin with a hyphen (`-`) or contain encoded double quotes (`%22`).

References

Community reviews

Loading reviews…