Skip to main content
VulnerabilityPublished Updated

CVE-2026-28370: OpenStack Vitrage · Eval Injection

Affects OpenStack VitrageSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 12.0.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade OpenStack Vitrage to 12.0.1.

Affected software

ProductAffectedFixed in
OpenStackVitrageAffected
  • <12.0.1
  • =13.0.0
  • =14.0.0
  • =15.0.0
Fixed in
  • 12.0.1
PyPIopenstack-vitragepkg:pypi/openstack-vitrageOther threatsAffected
  • 0 – 15.0.0
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-28370, organizations should immediately upgrade OpenStack Vitrage to a fixed version beyond 12.0.1 or versions later than 15.0.0 where the vulnerability is patched. If upgrading is not immediately feasible, restrict access to the Vitrage API to trusted and authenticated users only, ideally limiting API exposure to internal networks or VPNs. Implement strict API authentication and authorization controls to minimize the risk of malicious query injection. Employ runtime application monitoring and intrusion detection to identify anomalous query patterns or unexpected code execution behaviors. Review and harden the configuration of the Vitrage service user to limit privileges on the host system, reducing the impact of potential exploitation. Additionally, consider deploying web application firewalls (WAFs) or API gateways with custom rules to detect and block suspicious query inputs targeting the vulnerable function. Regularly audit logs for unusual API activity and prepare incident response plans for potential exploitation scenarios.

Description

In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in _create_query_function in vitrage/graph/query.py.

References

Community reviews

Loading reviews…