Skip to main content
VulnerabilityPublished Updated

CVE-2026-28411: LabRedesCefetRJ WeGIA · Authentication Bypass Using an Alternate Path or Channel

Affects LabRedesCefetRJ WeGIASource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 9.8 Critical : upgrade to 3.6.5 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.6% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade WeGIA and labredescefetrj/WeGIA to 3.6.5.

Affected software

ProductAffectedFixed in
LabRedesCefetRJWeGIAAffected
  • <3.6.5
Fixed in
  • 3.6.5
GitHublabredescefetrj/WeGIApkg:github/labredescefetrj/WeGIAOther threatsAffected
  • <3.6.5
Fixed in
  • 3.6.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-28411, organizations should immediately upgrade WeGIA to version 3.6.5 or later, where the vulnerability has been fixed. If upgrading is not immediately feasible, organizations should implement temporary mitigations such as disabling or restricting access to the vulnerable PHP scripts, especially from untrusted networks. Conduct a thorough code review to identify and remove unsafe use of extract() on superglobals like $_REQUEST, replacing it with explicit input handling and validation. Employ strict input validation and sanitization to prevent variable overwriting. Implement web application firewalls (WAFs) with rules to detect and block suspicious parameter manipulation attempts targeting authentication variables. Monitor logs for unusual access patterns or parameter tampering. Educate developers on secure coding practices to avoid similar vulnerabilities. Finally, conduct regular security assessments and penetration testing to detect and remediate such issues proactively.

Description

WeGIA is a web manager for charitable institutions. Prior to version 3.6.5, an unsafe use of the `extract()` function on the `$_REQUEST` superglobal allows an unauthenticated attacker to overwrite local variables in multiple PHP scripts. This vulnerability can be leveraged to completely bypass authentication checks, allowing unauthorized access to administrative and protected areas of the WeGIA application. Version 3.6.5 fixes the issue.

References

Community reviews

Loading reviews…