Skip to main content
VulnerabilityPublished

CVE-2026-28755: F5 NGINX Open Source · Incorrect Authorization

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.29.7 or 1.28.3 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.29.7, 1.28.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade F5 NGINX Open Source to 1.29.7 or 1.28.3.

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.29.0 <1.29.7
Fixed in
  • 1.29.7
F5NGINX Open SourceAffected
  • >=1.27.2 <1.28.3
Fixed in
  • 1.28.3
F5NGINX PlusAffected
  • >=R34
  • >=R33
  • =R36
  • =R35
Fixed in–

AI-suggested

To mitigate CVE-2026-28755, organizations should: 1) Upgrade affected NGINX Open Source versions (1.27.2 and 1.29.0) to patched releases once available from F5 or the NGINX project. 2) Temporarily disable ssl_ocsp or ssl_verify_client if immediate patching is not possible, understanding this reduces security and should be a short-term measure. 3) Implement additional layers of client authentication or authorization beyond TLS client certificates, such as application-level access controls or multi-factor authentication. 4) Monitor TLS handshake logs for connections using revoked certificates or unusual client certificate usage patterns. 5) Use OCSP stapling on the server side to improve revocation checking reliability and consider alternative revocation mechanisms like CRLs if feasible. 6) Restrict network access to NGINX servers requiring client certificates to trusted networks or VPNs to reduce exposure. 7) Conduct regular audits of client certificates and revoke any that are no longer needed or compromised. These steps help reduce the risk of unauthorized access while awaiting official patches.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_stream_ssl_module module due to the improper handling of revoked certificates when configured with the ssl_verify_client on and ssl_ocsp on directives, allowing the TLS handshake to succeed even after an OCSP check identifies the certificate as revoked. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…