Skip to main content
VulnerabilityPublished Updated

CVE-2026-28811: Apache JSPWiki · Debug Messages Revealing Unnecessary Information

Affects Apache JSPWikiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to up to 3.0.0 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in up to 3.0.0, 2.12.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache JSPWiki to up to 3.0.0; org.apache.jspwiki/jspwiki to 2.12.4.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache JSPWikiAffected
  • =0
Fixed in
  • up to 3.0.0
Mavenorg.apache.jspwiki/jspwikipkg:maven/org.apache.jspwiki/jspwikiOther threatsAffected
  • <2.12.4
Fixed in
  • 2.12.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache JSPWiki to version 2.12.4 or later to remediate this vulnerability. No other mitigation is indicated or required according to the vendor advisory.

Description

Apache JSPWiki versions prior to 2.12.4 contain a vulnerability where debug messages reveal unnecessary information. This issue is addressed in version 2.12.4. The vulnerability has a high severity score of 7.5 and is identified as CWE-1295.

References

Community reviews

Loading reviews…