CVE-2026-28813: Apache JSPWiki · Cross-Site Request Forgery (CSRF)
Affects Apache JSPWikiSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.12.4 soon.
Data as of 29 Oct 2026, 10:37 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache JSPWiki and org.apache.jspwiki/jspwiki to 2.12.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache JSPWiki | Affected
| Fixed in
|
Mavenorg.apache.jspwiki/jspwikipkg:maven/org.apache.jspwiki/jspwikiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache JSPWiki to version 2.12.4 or later, which contains the fix for this CSRF vulnerability. No other mitigations are indicated by the vendor advisory.
Description
Apache JSPWiki versions prior to 2.12.4 are vulnerable to a Cross-Site Request Forgery (CSRF) issue related to JSON Hijacking. This vulnerability allows an attacker to perform unauthorized actions on behalf of an authenticated user. The issue is fixed in version 2.12.4.