CVE-2026-28812: Apache JSPWiki · Use of Impersonation
Affects Apache JSPWikiSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.12.4 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache JSPWiki to 2.12.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache JSPWiki | Affected
| Fixed in
|
Mavenorg.apache.jspwiki/jspwikipkg:maven/org.apache.jspwiki/jspwikiOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache JSPWiki to version 2.12.4 or later, as this version contains the official fix for the impersonation vulnerability. No other mitigation or temporary workaround is indicated. Patch status is confirmed fixed in 2.12.4.
Description
UserManager lack of checks allows impersonation in Apache JSPWiki up to 2.12.3 which may allow attackers to escalate privileges. Users are recommended to upgrade to version 2.12.4 or newer which fixes this issue.