Skip to main content
VulnerabilityPublished Updated

CVE-2026-28814: Apache JSPWiki · Missing Authentication

Affects Apache JSPWikiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.12.4 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache JSPWiki and org.apache.jspwiki/jspwiki to 2.12.4.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache JSPWikiAffected
  • <2.12.4
Fixed in
  • 2.12.4
Mavenorg.apache.jspwiki/jspwikipkg:maven/org.apache.jspwiki/jspwikiOther threatsAffected
  • <2.12.4
Fixed in
  • 2.12.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache JSPWiki to version 2.12.4 or later, or to version 3.0.0, where this vulnerability is fixed. Patch status is confirmed by the vendor's recommendation to upgrade. No other mitigation or temporary workaround is indicated.

Description

CVE-2026-28814 is a high-severity vulnerability in Apache JSPWiki up to version 2.12.3 that allows arbitrary Wiki Markup rendering due to lack of authentication. This flaw enables an attacker to access sensitive data stored in JSPWiki variables without requiring any privileges. The issue is resolved in versions 2.12.4 and 3.0.0 by introducing proper authentication controls.

References

Community reviews

Loading reviews…